lctg.net
当前位置:首页 >> slF4j Api 1.5.8.jAr >>

slF4j Api 1.5.8.jAr

slf4j-api-1.5.8.jar不就是包么,要下载这个包,百度一下不就有了。

有很多啊,有Log4j,LogBack,甚至JDK自带的Logger都是slf4j的实现类。 你如果要使用Log4j,那么除了slf4j-api外还需要一个slf4j-log4j12(或slf4j-log4j13这个根据你的Log4j的版本来),你如果要使用JDK作为实现的话,那么除了slf4j-api外,还...

使用log4j记录日志需要导入的包

修改user对象里的roles 然后update(user); 如果把roles设置成null,那么update的时候用户就没有角色了。

slf4j.nop.jar是slf-api.jar其相应的接口实现, 把slf的接口对到log4j的实现 把slf的实现slf4j-nop-1.5.8.jar去掉,添加log4j的实现log4j-1.2.15.jar,再添加一个slf-api和log4j转换器slf4j-log4j12-1.5.8.jar. 把slf的接口转换成log4j的接口.最后...

slf4j.nop.jar是slf-api.jar其相应的接口实现, 把slf的接口对到log4j的实现 把slf的实现slf4j-nop-1.5.8.jar去掉,添加log4j的实现log4j-1.2.15.jar,再添加一个slf-api和log4j转换器slf4j-log4j12-1.5.8.jar. 把slf的接口转换成log4j的接口.最后...

这个是弄日志的哦。commons-logging-1.0.4.jar log4j-1.2.15.jar slf4j-api-1.5.8.jar slf4j-log4j12-1.5.8.jar加上这几个jar包。再在你的src包下加上 logging.propeties这个文件就好了。如果不想用log4j-1.2.15.jar 的话。commons-logging-1.0....

在引用了这个包中的class的地方,删除重新引用一次。

-sources是源码

错误显示你的slf4j的包版本有点老,它需要1.6版本的,你的接口貌似是1.5.8版本的

网站首页 | 网站地图
All rights reserved Powered by www.lctg.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com